• Find us:
    +1-669-900-5138   |   +44-203-372-5553
  • Free Newsletter

    Get Latest Updates

  • Make Training Enquiry


    Company

  • Categories

  • Archive

  • Unclean shutdown of previous Apache run? *** glibc detected *** realloc(): invalid size: 0x0819e4a8 *** : Issue while restarting HTTP Server

    Posted by "" in "idm, oam, ohs, troubleshooting" on 2010-09-01

    Share on FacebookTweet about this on TwitterShare on Google+Share on LinkedInEmail this to someone

    There is a known issue when Oracle Access Manager components such as WebPass, Policy Manager and WebGates are installed on Oracle HTTP Server.

    Typically, while installing the WebPass (say) , the httpd.conf of HTTP Server will be pointed out and after the webpass configurations are updated in the httpd.conf, the Http Server should be restarted.

    The below error was encountered in Apache error log while restarting HTTP Server

    /u01/osinfra/Apache/Apache/logs/httpd.pid overwritten — Unclean shutdown of previous Apache run?
    *** glibc detected *** realloc(): invalid size: 0x0819e4a8 ***

    This is because of the perl module in the Apache server.

    Edit the httpd.conf and comment the below line.

    LoadModule perl_module libexec/libperl.so

    Attempt to start the HTTP Server is succesful.

    11 Responses to “Unclean shutdown of previous Apache run? *** glibc detected *** realloc(): invalid size: 0x0819e4a8 *** : Issue while restarting HTTP Server”

    1. Rashmi says:

      Hi,

      After installing WebPass I encountered the same error:

      pid file /home/oracle/app/oracle/admin/ohs_inst1/diagnostics/logs/OHS/ohs1/httpd.pid overwritten — Unclean shutdown of previous apache run?

      The following line

      LoadModule perl_module libexec/libperl.so

      is missing from the httpd.conf file.

      Do you suggest other solutions to overcome this problem?

      Thanks.

    2. mahendra says:

      Hi Rashmi,

      I encountered this error in OHS 10g. I believe you must be using OHS 11g. Can you confirm whether the issue is resolved or not?

      Thanks,
      Mahendra.

    3. Rashmi says:

      Mahendra,

      Thanks for the response. Yes I am using OHS 11g and still facing this issue. It is not yet resolved.

      Rashmi

    4. mahendra says:

      Hi Rashmi,

      Can you try commenting out libphp4 line as well as shown below.

      #LoadModule php4_module libexec/libphp4

      Please let me know the results.

      Thanks,
      Mahendra.

    5. Rashmi says:

      Mahendra,

      That line is not present in my httpd.conf file either.

      I am using OAM 10.1.4.3.0 with OHS 11g. I gather from https://forums.oracle.com/forums/thread.jspa?threadID=946594 that there are compatibility issues. Is there a solution to this?

      Thanks,
      Rashmi

    6. mahendra says:

      Rashmi,

      The forum thread you mentioned is talking about 64-bit to 32-bit compatibility issues. Your issue is different. However, I would like to know your environmental details to suggest solution.

      Thanks
      Mahendra.

    7. Rashmi says:

      Mahendra,

      I am using Oracle Linux 4/5 (64 bit). I am trying to install the OIM components in order to deploy Oracle Fusion Applications. I have successfully installed the following components till now:

      Oracle Database 10g
      Repository Creation Utility
      OHS 11g
      WebLogic Server 11g
      Identity Manager
      SOA
      Identity and Access Manager
      OID
      ODSM
      OAM 10g

      Then I tried to install WebPass for OHS 11g. That’s when I faced this issue.

      Would any other details be required?

      Thanks,
      Rashmi

    8. mahendra says:

      Rashmi,

      I think it could be due to purely a compatibility issue. Where did you get the gcc libraries for 64-bit environment? What version 32-bit or 64-bit of WebPass are you using?

      You can try to copy the gcc libraries directly from the OS and give a shot?

      Please paste the complete error you are getting while starting the http server after installing webpass, also the log file content.

      Thanks,
      Mahendra.

    9. Rashmi says:

      Hi Mahendra,

      I did use the gcc libraries that were shipped with the OS.

      The WebPass installer is 32 bit however.

      The error I’m getting is:

      $ ./opmnctl startall
      opmnctl startall: starting opmn and all managed processes…
      ================================================================================
      opmn id=vWKSTN159B.exeterblr.com:6702
      0 of 1 processes started.

      ias-instance id=ohs_inst1
      ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
      ——————————————————————————–
      ias-component/process-type/process-set:
      ohs1/OHS/OHS/

      Error
      –> Process (index=1,uid=273695967,pid=28914)
      failed to start a managed process after the maximum retry limit
      Log:
      /home/oracle/app/oracle/admin/ohs_inst1/diagnostics/logs/OHS/ohs1/console~OHS~1.log

      Log file content:

      Log file:

      11/09/07 06:31:03 Start process ——– /home/oracle/app/oracle/product/fmw/web/ohs/bin/apachectl startssl: execing httpd httpd.worker: Syntax error on line 1047 of /home/oracle/app/oracle/admin/ohs_inst1/config/OHS/ohs1/httpd.conf: Cannot load /home/oracle/app/oracle/product/fmw/oam/webcomponents/identity/oblix/apps/webpass/bin/libwebpassssl.so into server: /home/oracle/app/oracle/product/fmw/oam/webcomponents/identity/oblix/apps/webpass/bin/libwebpassssl.so: wrong ELF class: ELFCLASS32

      Thanks,
      Rashmi

    10. mahendra says:

      Rashmi,

      I hope you must be using right installer, so would not ask you about that. I am sure that this error it is due to compatibility issues. Since you said you had already tried with OS gcc libs, there are gcc libraries provided by Oracle for 64-bit linux systems, may be you try that.

      Hope this helps.

      -Mahendra.

    11. Atul Kumar says:

      @ Rashmi,
      Are you using SSL for webgate to OAM server communication ? If not comment entry /home/oracle/app/oracle/ product/fmw/oam/webcomponents/ identity/oblix/apps /webpass/bin/libwebpassssl.so

      and then start web server

    Leave a Reply



  • K21 Technologies is among the most experienced Oracle Gold Partner for Identity Access Management service providers. We work with application development companies and in-house technology division to help achieve significant returns on their IT security investment. Our clientele includes some of the globally renowned corporate, which speaks of our expertise in our field.

    We have the most talented and experienced team that can swiftly deploy security solutions even in complex IT ecosystem. Our clients highly appreciate our timely implementation, interactive training, on-demand support and community resources.
  • CONTACTS

    K21 Technologies
    8 Magnolia Place, Harrow,
    London, HA2 6DS

    UK: +44(0)7476444481
    USA: +1-888-414-1821

  • 2014, K21 Technologies. All rights reserved DMCA.com
  • TOP